Vaak gestelde vragen
MyBBoard > Support > Vaak gestelde vragen

Stel een vraag:


Upgrade Gids

Oplossing Hoe upgrade ik een MyBB forum?

Bij MyBB zijn er verschillende soorten upgrades, welke afhangen van de grootte, moeilijkheidsgraad of type van de update.

Voorbereiding
• Als eerste kan u best uw forum sluiten, dit voorkomt dat één van uw gebruikers het updateproces zou onderbreken. Hierbij volstaat het NIET om gewoon uw forum op het BeheerdersCS online/offline te plaatsen. U kan best via een .htaccess bestand uw gebruikers blokkeren of omleiden naar een pagina met een melding. Meer informatie kan u hier vinden;
• Voor u aan de update kan beginnen is het aangeraden om een backup te maken. Meer info hierover vindt u hier. Vergeet ook niet om een backup van uw bestanden te maken, zo kan u -wanneer er toch iets zou fout gaan tijdens het updaten- steeds uw forum makkelijk herstellen;
• Wanneer u een hoofdupdate doet (mybb 1.4 => 1.6) moet u uw plugins uitschakelen. Dit omdat sommige niet gaan werken met de nieuwe versie en problemen gaan veroorzaken. Voor kleinere updates (1.6.2 => 1.6.3) is dit meestal niet nodig.

Start de upgrade

Volledige upgrade
Indien u meer dan 1 versie gaat updaten (1.6.1 => 1.6.3 of 1.4.x => 1.6.x) dan moet u een volledige upgrade doen. Dit wil zeggen dat u de laatste versie download, deze bestanden upload en het update script uitvoert.

Changed files upgrade
Als u slechts 1 versie moet updaten (1.6.2 => 1.6.3) zijn 'changed files' beschikbaar. Dit zip bestand bevat enkel de bestanden die veranderd zijn deze update. Het volstaat dat u deze upload en e.v.t. het upgradescript uitvoert. Meer informatie en de download kan u vinden bij de betreffende aankondiging van deze update op ons forum.

• Upload alle bestanden naar uw forum map.

• Als in de nieuwsmelding staat dat u het upgradescript moet uitvoeren:
1) Verwijdert u het "lock" bestand in forum_root/install/, bezoek dan forum_root/install/ en volg dan de instructies (waar forum_root het webadres voor uw forum is).
Wanneer u in de 1ste stap een drop-down menu krijgt die een versie vraagt, moet u de versie opgeven die uw forum NU heeft, dus NIET de versie die u pas heeft gedownload en waarnaar u wil upgraden.
2) Na de upgrade moet u nakijken of er in de map /install/ een bestand 'lock' aangemaakt is. Indien dit niet het geval is kan u best de map /install/ verwijderen.
Voor extra beveiliging: chmod inc/config.php naar 644.

• Als in de nieuwsmelding staat dat er thema veranderingen zijn:
1) Ga op uw BeheerdersCS naar 'sjablonen en thema's' => sjablonen => 'Gewijzigde sjablonen'.
2) Hier kan u de gewijzigde sjablonen 'door origineel vervangen' (Dit zal al uw gemaakte wijzigingen verwijderen) - of de verschillen bekijken. Indien u zelf wijzigingen hebt gemaakt kan u best de verschillen bekijken en de veranderingen die nodig zijn uitvoeren.

• Nu kan u uw forum weer openen door het .htaccess aan te passen. Kijk ook zeker alles grondig na of u nergens foutmeldingen krijgt.
Artikel details
Artikel ID: 19
Categorie: Installatie/Upgrade
Datum toegevoegd: 2011-07-27 13:38:41
Aantal bekeken: 2336

 
<< Ga terug

Powered by Help Desk Software HESK™